babel 可以将ES6 的语法、新特性编译为 ES5 版本,以便在不支持 ES6 的浏览器里面可以使用,本文简单介绍一下 babel 的使用:

使用方法:

  • 第 0 步:npm init 生成 package.json 文件
  • 第一:全局安装 babel-cli 通过命令:npm install -g babel-cli
  • 第二:安装 babel-preset-env开发依赖 通过命令 : npm install babel-preset-env --save-dev
  • 第三:在当前目录下创建 .babelrc 配置文件,内容如下:

    1
    2
    3
    {
    "presets": ["env"]
    }
  • 第四:更改 package.jsonscripts 字段

    1
    2
    3
    4
    5
    6
    7
    "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1",
    "build": "babel js -d dist"
    //意思是运行npm run build 相当于 babel js -d dist
    //这里 build 可以随便取名字
    //将当前目录下 js 文件夹里面的 js 文件 编译到 dist 文件
    },

第五:在当前目录,执行命令 npm run build